0 Members and 1 Guest are viewing this topic.

*

Offline AlbertCo zforce

Exhaust broke again
« on: June 25, 2017, 03:28:58 PM »
When my bike was in getting the oil in air filter fixed dealer replaced the complete exhaust ;said it was cracked @ 1600km . Now the bike has 2100km and it is broke again [bad this time ] Also all the suspension bushings are gone and I grease every trip . I told the dealer I think part of the problem is the bike rides so rough. I have backed the springs off as much as I can and tried to adjust the shocks several times but it really does not make any difference .My son in law got me to go with him ; he put new bighorns on his 2012 rzr 800 and he thought it rode alittle rough . I told him if I could get mine to ride half as smooth I would do the dance of joy . His is not a sport model just a stock rzr .

 Any ideas

Thanks

*

Offline NMKawierider

Re: Exhaust broke again
« Reply #1 on: June 25, 2017, 04:07:58 PM »
I finally got mine to ride half way decent but with these short a-arms its pretty tough. I had to replace most of my a-arm bushings with custom RzR 800 bushings, extend the travel length by using 1.5" wheel spacers, setting the tire air pressure to between 8-9psi and set the shocks as listed below.

All compressions set to center plus 2 clicks (2-clicks to the fast from center)
All rebounds set to center minus 2 clicks (2-clicks to the slow from center)
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | 9.7" GPS | Bandit Springs Rear & Gen-3 Shocks Front

My Videos On YouTube

*

Offline AlbertCo zforce

Re: Exhaust broke again
« Reply #2 on: July 07, 2017, 06:53:45 PM »
Finally getting bike back tomorrow with a new updated muffler and all new bushings . Have been waiting for muffler for 3 weeks . Starting to get a little more than frustrating , seams that every time it goes to the dealer have to wait weeks for parts   

*

Offline REDRIDER

Re: Exhaust broke again
« Reply #3 on: July 08, 2017, 07:29:29 AM »
Yea when i researched these before i bought mine i saw lots of posts about yea there's a big warehouse in the US with parts so it's not a problem getting parts.  Yea right.  Apparently they must only stock oil filters in there because anything I've needed had to come from china.... 3 weeks for a wheel... really a wheel

*

Offline AlbertCo zforce

Re: Exhaust broke again
« Reply #4 on: July 08, 2017, 06:37:18 PM »
Picked up my bike this morning exhaust is fixed but the bushings were the wrong ones again . They told me to drive it because it really will not hurt anything and when the proper ones come in they will call me. I don't expect to hear anything for atleast 3 or 4 weeks then back to the dealer . If it wasn't under warrenty I would see what I could find