0 Members and 1 Guest are viewing this topic.

*

Offline Scottzforce800

Blown Fuse
« on: March 27, 2016, 06:45:14 PM »
 Hey guys just looking for some help.  I keep blowing a 10 amp fuse  in the fuse holder beside the steering wheel.  When this fuse blows I lose power to the instrument panel where the gas gauge miles per hour and temperature is.  I also lose the 4 Wheel Dr. function as well as the lights and horn.   Has anyone else had this problem and what did you do to fix it? 
2015 Zforce 800EX

*

Online NMKawierider

Re: Blown Fuse
« Reply #1 on: March 27, 2016, 08:25:52 PM »
Fuses blow for a reason. Something on that circuit is pulling too much power or there is a short somewhere. Start checking the wiring harness for rub spots. I have to ask..have you added and accessory lately?
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | 9.7" GPS | Bandit Springs Rear & Gen-3 Shocks Front

My Videos On YouTube

*

Offline Scottzforce800

Re: Blown Fuse
« Reply #2 on: March 27, 2016, 09:53:17 PM »
Yes, I have light bar in front and a little one in the back for a back up light. Both have harness with relays and fuse. Both are ran straight to battery and are not wired into factory harness anywhere. I have looked and so far do not see any naked wires, unit is less than year old and so far everywhere I have looked wires look really good. I still have warranty but hate to go hour and half plus loose my machine for another month.
2015 Zforce 800EX

*

Offline gfmoto

Re: Blown Fuse
« Reply #3 on: April 08, 2016, 01:24:03 PM »
Make use of that warranty while you have it. Nicer weather is on its way, and I'd say sacrifice the time now while under warranty rather than time and money down the road.
May be something so small you can see it or something in the 4WD switch or in the dash.
In either case wiring/electrical problems are sometimes the hardest to track down.
Try to take note of ANYTHING that you touch ,see,hear, when it blows. May help you to find the cause. 
2015 ZForce 800EX
32" light bar
2-4" spots
Custom Cv guards
DIY 1/2 windshield
UNI air filter
DIY rear window
BOSS ATV 28. 450W speakers
Alpena Rock Lights (tough pods)
2" RZR Bracket lift
Roof extensions
27" Maxxis Corranado Tires
Alpena RGB rock lights
SuperATV Rocksliders
1/2 Doors w/custom paint and graphics

*

Offline Scottzforce800

Re: Blown Fuse
« Reply #4 on: April 18, 2016, 06:35:53 PM »
Turns out after taking it to the dealer that the dealer that changed the engine out during rebuild (which was different dealer) did not tie the wires back up going to speed sensor and had rubbed hole and shorted out. Dealer took care of and all seems well with that problem.
2015 Zforce 800EX

*

Offline gfmoto

Re: Blown Fuse
« Reply #5 on: April 18, 2016, 06:41:40 PM »
Great news!! Glad they were able to find the problem and fix it.
2015 ZForce 800EX
32" light bar
2-4" spots
Custom Cv guards
DIY 1/2 windshield
UNI air filter
DIY rear window
BOSS ATV 28. 450W speakers
Alpena Rock Lights (tough pods)
2" RZR Bracket lift
Roof extensions
27" Maxxis Corranado Tires
Alpena RGB rock lights
SuperATV Rocksliders
1/2 Doors w/custom paint and graphics