0 Members and 1 Guest are viewing this topic.

*

Offline Ukhozi

Fforce 550ex dead but not dead
« on: August 08, 2018, 10:21:44 am »
Vehicle stopped at the end of a tour and although the dash lights up nothing happens on turning to 'start'.

I have checked the starter relay by bridging battery input terminal  to signal input (yellow) and the relay works and motor turns over OK. Traced that back to fuse box and same from there, so not a wiring issue as far as the starter system goes.

I connected the Green white wire on relay (switched ground), goes to brown/white at ECU)  in fuse box to ground via a test lamp and it turned over on the key but no spark or pump

Any ideas, ECU?  Start inhibit system, I tried in P and N. also bridged brake switch in case the brake light switch was faulty.

Peter

*

Offline Ukhozi

Re: Fforce 550ex dead but not dead
« Reply #1 on: August 09, 2018, 03:19:15 pm »
It WAS the ecu. Swapped one from a crashed runner and fired up straight away.

*

Offline Ukhozi

Re: Fforce 550ex dead but not dead
« Reply #2 on: August 17, 2018, 10:27:00 am »
Having cured the first one with a new ECU another one died, same symtoms but after an ECU swap that was ruled out.( by the way, you can undo the two bolts holding the ucu by reaching in under the 2/4selector with a 1/4 drive and 10mm socket.)
Anyway, turned out to be the engine kill switch, stripped, cleaned and refitted good as new, it was very dirty with dust so
DO NOT OIL OR GREASE switch internals.

'Nuvver tip, the mini relays in the fuse box can be installed 180° out. The small reccesed dot in the top goes away from the two bigger relays.
« Last Edit: August 17, 2018, 10:29:21 am by Ukhozi »