0 Members and 1 Guest are viewing this topic.

*

Offline High Altitude Adventures

2018 Zforce 500 wont start
« on: July 26, 2018, 07:28:54 pm »
2018 Zforce 500 wont start. It came back off  the mountain having trouble pulling up hills and starting..seemed to be a fuel problem. There were and still aren't any makfunction lights or codes. cleaned air filter changed fuel filter, the fuel , the injector, the spark plug , checked all the fuses. fuel is making it out of the new injector (old was clogged) the spark plug is gapped properly and sparking. still wont start.

*

Offline NMKawierider

Re: 2018 Zforce 500 wont start
« Reply #1 on: July 26, 2018, 07:46:02 pm »
Check the compression. If it has fuel,air and ignition at the right time with adequate compression, it has to run. There are some that have has timing chain issues but a comp-test will show low compression due to that or rings gone because of particle ingestion. Hopefully you were not running the factory air filter. 
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline High Altitude Adventures

Re: 2018 Zforce 500 wont start
« Reply #2 on: July 26, 2018, 08:11:06 pm »
will check compression tomorrow thanks and yes was running stock air filter. After the engine rebuild/replacement what air filter is everyone using on these and has anyone relocated the intake. I did notice dust on the inside of the hose on what should be the clean side of the filter. has anyone had experience with this company and their warranty ? This machine is less than a month off the showroom floor

*

Offline NMKawierider

Re: 2018 Zforce 500 wont start
« Reply #3 on: July 26, 2018, 08:35:32 pm »
will check compression tomorrow thanks and yes was running stock air filter. After the engine rebuild/replacement what air filter is everyone using on these and has anyone relocated the intake. I did notice dust on the inside of the hose on what should be the clean side of the filter. has anyone had experience with this company and their warranty ? This machine is less than a month off the showroom floor
Most of us have had that experience with dust making it past the stock filters. In fact that and heat are the #1 killers of these engines. Some don't make it 500 miles...but others go quite a while with the stock filters-probably in the wet country :) We all go with the Unifilter dual stage foam filters with quality foam filter oils. Yours..should be warrantied if that's what's happened. Your dealer may want to put on a different CFM filter or a TwinAir. Insist on UniFilter. I'm not sure what one the 500s take but someone here will know. 
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline REDRIDER

Re: 2018 Zforce 500 wont start
« Reply #4 on: July 27, 2018, 02:09:46 pm »
Should be warranty

*

Offline Ukhozi

Re: 2018 Zforce 500 wont start
« Reply #5 on: August 09, 2018, 03:21:32 pm »
Had just that on Monday, tight valves.

*

Offline IMPALADAKID

Re: 2018 Zforce 500 wont start
« Reply #6 on: August 12, 2018, 08:53:41 am »
Does it still Warranty? Why not just drop it off at the dealer?