0 Members and 1 Guest are viewing this topic.

*

Offline rj2wenlrn

zforce 800ex won't idle
« on: September 01, 2019, 09:22:31 AM »
Hello, My first time here.
I have a 2014 zforce 800ex that is now idling rough.  Had it out all day no issues.  Was heading home a got up to about 55 then the power cut out so I coasted to a stop but the motor stayed running.  The dash light came on when the engine seems to shut down. Once I came to a stop it took off again and seemed to run fine.  But now it doesn't want to idle.  I cleaned the uni air filter since I was in the dust all day but that didn't help. 
Any ideas?

*

Offline NMKawierider

Re: zforce 800ex won't idle
« Reply #1 on: September 01, 2019, 09:33:04 AM »
Hello, My first time here.
I have a 2014 zforce 800ex that is now idling rough.  Had it out all day no issues.  Was heading home a got up to about 55 then the power cut out so I coasted to a stop but the motor stayed running.  The dash light came on when the engine seems to shut down. Once I came to a stop it took off again and seemed to run fine.  But now it doesn't want to idle.  I cleaned the uni air filter since I was in the dust all day but that didn't help. 
Any ideas?
Well, what dash light came on? You will need to run some tests like fuel pressure and volume test as the tank vent check valve as it may be stuck or a fuel filter issue or fuel pump. Test power-power to the coils,battery power, charging levels cause low power can do that too. Check valve lash and timing cause older CFMs have had chain issues. Test the CPS and the TPD. That's all in the service manual. All part of the process.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | 9.7" GPS | Bandit Springs Rear & Gen-3 Shocks Front

My Videos On YouTube

*

Offline rj2wenlrn

Re: zforce 800ex won't idle
« Reply #2 on: September 01, 2019, 10:08:40 AM »
Thanks NMK.  It was the MIL light that came on. It went off once I came to a stop.  It has a new battery and fuel filter.

*

Offline NMKawierider

Re: zforce 800ex won't idle
« Reply #3 on: September 01, 2019, 11:29:07 AM »
Thanks NMK.  It was the MIL light that came on. It went off once I came to a stop.  It has a new battery and fuel filter.
Then as it was the MIL light, the ECM is registering an error from one of the inputs/sensors. Just need to find which one..its obviously one that effects running so..start there.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | 9.7" GPS | Bandit Springs Rear & Gen-3 Shocks Front

My Videos On YouTube

*

Offline rj2wenlrn

Re: zforce 800ex won't idle
« Reply #4 on: September 01, 2019, 04:05:34 PM »
Thank you for the advice!