0 Members and 1 Guest are viewing this topic.

*

Offline desertrat

Starting
« on: September 01, 2019, 08:01:22 PM »
I have a 2018 Z500 trail and all of a sudden it wll not start. all it does it turns over but will not fire. air filter clean, mass air senor clean, fuel injector has fuel coming out, fuel pump starts then stop like it should fuses good, battery good. the EFI light just flashes continuously as soon as the key is on. if there is a code i cant make out a code, was running fine one weekend then the next weekend was a no go. just checking for ideas before it goes to the shop. other then that no problems

*

Offline NMKawierider

Re: Starting
« Reply #1 on: September 01, 2019, 08:36:43 PM »
See if it has spark and compression. If so check the compression. If it has air,fuel,compression and spark at the right time, it has to run. Something is missing...just got to find out what.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | 9.7" GPS | Bandit Springs Rear & Gen-3 Shocks Front

My Videos On YouTube

*

Offline desertrat

Re: Starting
« Reply #2 on: September 01, 2019, 09:50:26 PM »
yes it has spark new plug and compression within specs. wont even start with starting fluid all senors seem to be workinmg properly

*

Offline doug80638

Re: Starting
« Reply #3 on: September 02, 2019, 08:19:14 AM »

Given what you've provided, and using starter fluid, my bet is that the spark plugs aren't being fired, and I would take steps to test that system.

The EFI flashing tells us it's unhappy about one or more circuits. First step is to dump any available codes. This is done with a reader (dealership will have these) or installing a jumper on the K-line. (There are posts in this forum for that).

Checking electrical connections is also prudent.
2017 Zforce 800 - Red
SuperATV Flip windshield
Tusk soft rear window
Uni-Filter foam air filter
Bandit springs

*

Offline eg78

Re: Starting
« Reply #4 on: September 07, 2019, 09:58:12 AM »
I have a 2018 Z500 trail and all of a sudden it wll not start. all it does it turns over but will not fire. air filter clean, mass air senor clean, fuel injector has fuel coming out, fuel pump starts then stop like it should fuses good, battery good. the EFI light just flashes continuously as soon as the key is on. if there is a code i cant make out a code, was running fine one weekend then the next weekend was a no go. just checking for ideas before it goes to the shop. other then that no problems

Try fiddling with the killswitch button. On mine I started just using the key and not starting/stopping using the killswitch. 1 out of 2 times it wont start until I push it in and out a few times... Give that a try.. sounds simple but it worked for me after the dealer found no issue.

*

Offline desertrat

Re: Starting
« Reply #5 on: September 21, 2019, 05:23:35 PM »
UPDATE:
just got it back from shop. the valves were at a negative and the exhaust valves was loose. they cleared the codes and gave it its first service.  runs good now  time to pack of the toys and go play

*

Offline doug80638

Re: Starting
« Reply #6 on: September 22, 2019, 06:59:09 AM »

Did they tell you what codes were being reported? That could be helpful to someone in the future.

Not sure what "valves were at a negative" means either.

"Exhaust loose" sounds like they did a lash adjustment.
2017 Zforce 800 - Red
SuperATV Flip windshield
Tusk soft rear window
Uni-Filter foam air filter
Bandit springs

*

Offline desertrat

Re: Starting
« Reply #7 on: September 22, 2019, 09:25:51 PM »
no on the codes   intake valves were negative clearance what ever that means so they sey all valves to specs.  i still say take/ build these buggies with out the calif. crap on them and they would run better

*

Offline doug80638

Re: Starting
« Reply #8 on: September 23, 2019, 06:55:40 AM »

The lash adjustment is a good thing. But that's not why it would not start.

There is something they aren't telling you.

But no matter, as whatever it was, it's fixed. Drive it like you stole it :-)
2017 Zforce 800 - Red
SuperATV Flip windshield
Tusk soft rear window
Uni-Filter foam air filter
Bandit springs