0 Members and 1 Guest are viewing this topic.

*

Offline Scooterb

EPS 40 amp fuse melted
« on: July 05, 2018, 04:09:10 pm »
Hi,
The fuse under the seat for the Electronic Power Steering melted. Has anyone experienced this before and what would cause it to do so?

Thanks!

*

Offline NMKawierider

Re: EPS 40 amp fuse melted
« Reply #1 on: July 05, 2018, 04:39:19 pm »
I have not but heard of some main fuse holders doing that. It's from a bad crimps or connections internally. The fix is replace it with a fuse holder that ..well isn't made in China..and one that can handle far more amps that the fuse you put in it. I have use the Maxi blade fuse and holders in other machines on their power steering with no issues. Rated at 60 amps you can put 20-60 amp fuses in it. These are not your regular holders..they are huge and have #8 gauge cable on them..The fuses are not cheap! They are over 3-bucks each.  I have several extra and will take a quick video if you like comparing between the two types. This is a Maxi:
https://www.amazon.com/dp/B00030CPOQ/ref=sxbs_sxwds-stvpv2_2?pf_rd_m=ATVPDKIKX0DER&pf_rd_p=3233965245922079678&pd_rd_wg=woKVe&pf_rd_r=JM2BND5A7T5N02K40AWJ&pf_rd_s=desktop-sx-bottom-slot&pf_rd_t=301&pd_rd_i=B00030CPOQ&pd_rd_w=LkCaS&pf_rd_i=Maxi+50+amp+fuse+holder&pd_rd_r=05a35a8a-9566-427e-8262-58f149d197d6&ie=UTF8&qid=1530826901&sr=2
Here's one that comes with a 50 amp fuse

https://www.amazon.com/Maxi-Fuse-Holder-Leads-Tinned/dp/B01GQHTKC4/ref=sr_1_3?ie=UTF8&qid=1530826312&sr=8-3&keywords=50+amp+fuse+holder
« Last Edit: July 05, 2018, 04:46:47 pm by NMKawierider »
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Scooterb

Re: EPS 40 amp fuse melted
« Reply #2 on: July 06, 2018, 10:22:00 am »
Thanks! I did just that and it works fine now.

*

Offline NMKawierider

Re: EPS 40 amp fuse melted
« Reply #3 on: July 06, 2018, 10:49:55 am »
Good. If you ever find any other connections getting warm or hot, that is the reason and they should be replaced. I found several on mine that I even have a voltage drop on that needed replaced.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube