0 Members and 1 Guest are viewing this topic.

*

Offline Workhardplayhard

Oil pressure light flashing!
« on: January 23, 2018, 06:08:52 PM »
Help! I'm coming up short trying to figure this out. When it's cold it will flash intermittent. I thought it was in the wiring and have checked all the wiring and connections. Even put electrical lube on all of the connections including the pressure sensor. It was only coming on a couple times after start up. But once it's up to temperature it never stops flashing. I have poured through the owners and service manuals and can't find any information on the sensor. If I had an idea of what resistance it should be I could test it.
 Thanks for your help!
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #1 on: January 23, 2018, 06:24:26 PM »
I would think...and this is just a good guess..that the sensor is just a pressure switch that once it is below...say..6psi, it just closes and makes a ground for the light. Pull the lead off it and see what it does with the key on but not started, then start it and let us know what you see. In the meantime I'll take a look at the wiring diagram.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #2 on: January 23, 2018, 06:57:33 PM »
With engine off and key on- light is on solid with and without pressure sensor plugged in. With engine on and sensor unplugged light is off. And it's cooled off now so it's back to being intermittent.
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #3 on: January 23, 2018, 07:06:41 PM »
With engine off and key on- light is on solid with and without pressure sensor plugged in. With engine on and sensor unplugged light is off. And it's cooled off now so it's back to being intermittent.
So..you are saying..unpluging the sensor doesn't make any difference in how it operates?
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #4 on: January 23, 2018, 07:26:25 PM »
With engine off and key on- light is on solid with and without pressure sensor plugged in. With engine on and sensor unplugged light is off. And it's cooled off now so it's back to being intermittent.
So..you are saying..unpluging the sensor doesn't make any difference in how it operates?
Nope. It keeps running just fine. I have doubts it's an actual pressure problem. As this problem started almost 10 miles from the truck. I of course shut it off and checked the oil on the trail. But it was full and clean. Is got us back to the truck and doesn't make any strange sounds. I took it home and changed the oil and filter. It was nice clean oil. That's when I tore it apart and checked all the wires.
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #5 on: January 23, 2018, 07:49:09 PM »
Well, I meant how the indicator acted..but anyway, the wiring diagram shows it to be just a switch but...the indicator in the pod has something interesting. It has a seperate circuit to the ECU that is shared with the tachometer. I snipped and marked it. So, the ECU can also cause or play a part on how it operates..or visa-versa. Have you tried resetting your maintenance indicator?

   
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #6 on: January 23, 2018, 08:32:21 PM »
I noticed it went to the ecu also. I even pulled the ecu out wile checking all the wiring. But I didn't realize it had a maintenance indicator. I'll get the owners manual back out and look for that. Thanks
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #7 on: January 23, 2018, 08:42:53 PM »
Yeah when I look at the indicators on the 500 HO, I don't see a separate one for maintenance..which is just an oil change reminder...so..and that's something from the ECU.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #8 on: January 23, 2018, 09:03:11 PM »
I don't see anything about a maintenance reminder. And all it says about the oil pressure light is
"oil pressure warning light: when the engine lubrication oil pressure is abnormal, the light is on, and off when it's normal"

It doesn't say anything about a flashing light.
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #9 on: January 23, 2018, 10:25:27 PM »
Maybe try the same thing that shuts the others off... hold down both buttons then while holding down, turn the key to the on position then let go of the bottoms.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #10 on: January 24, 2018, 08:07:57 AM »
Ok, I warmed it up this morning until the light was flashing nonstop. Tried the reset and nothing. If I hold the buttons down long enough everything goes blank except for a number 705 in the middle of the screen.
🇨🇱 2016 Cforce 500 HO

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #11 on: January 24, 2018, 09:12:51 AM »
Ok, I warmed it up this morning until the light was flashing nonstop. Tried the reset and nothing. If I hold the buttons down long enough everything goes blank except for a number 705 in the middle of the screen.
Yeah that's the speedo calibration number.
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

*

Offline Workhardplayhard

Re: Oil pressure light flashing!
« Reply #12 on: January 24, 2018, 09:30:44 AM »
Ok, I warmed it up this morning until the light was flashing nonstop. Tried the reset and nothing. If I hold the buttons down long enough everything goes blank except for a number 705 in the middle of the screen.
Yeah that's the speedo calibration number.
That's what I thought. I was thinking I had read about that on here somewhere.
But back to the flashing light. I'm just perplexed. And I'm getting really tired of working on this thing more than I ride it. It still only has 285 miles on it. I'm about ready to sell it and go back to Kawasaki.
🇨🇱 2016 Cforce 500 HO

*

Offline Wheels

Re: Oil pressure light flashing!
« Reply #13 on: January 24, 2018, 09:38:57 AM »
I would remove the sensor blow it out with low pressure air and reinstall.
Wire unplugged, engine running = no light?
Wire unplugged , engine running, no ground the wire, flashing?
This sensor can get stuff stuck in them and on the 500 engine don't like to be filled to high with oil.
I have seen many overfilled or right on the full line and the sensor grounds out an turn the light on.
If after you have tried blowing out the sensor and still acting up, change it out and I'm very sure the problem will be gone.
Link to a cheap sensor.
http://online.mortch.com/CFMoto-CF800cc-ATV-UTV-2V91-Oil-Pressure-Switch-01A0-012200-250cc-400cc-450cc
If it has Pistons or Tits you will encounter problems.

*

Offline NMKawierider

Re: Oil pressure light flashing!
« Reply #14 on: January 24, 2018, 09:39:30 AM »
I say take it in and tell them fix this fk'er ...and it better not cost me anything.
« Last Edit: January 24, 2018, 09:41:25 AM by NMKawierider »
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube