Author Topic: correct oil  (Read 1258 times)

0 Members and 1 Guest are viewing this topic.

Offline Kurt

  • Junior Member
  • **
  • Posts: 17
    • View Profile
  • Location: Alberta
correct oil
« on: July 12, 2017, 12:11:09 AM »
What is the correct oil to run in these engines? I've gotten conflicting information ;When I phone support they said lucas 0w40 engine oil but also said it doesn't have a wet clutch. But the service manual seems to say its got a wet clutch. Lucas has 0w40 in both Soooo anyone know what I actually need?

Thanks :)
« Last Edit: August 03, 2017, 01:09:08 AM by Kurt »

Offline Cosmosdan

  • Guru
  • *****
  • Posts: 1691
    • View Profile
  • Location: SW MN
Re: correct oil
« Reply #1 on: July 12, 2017, 10:05:51 AM »
The 400 and newer 500 does not have a wet clutch. It has a cvtech trailbloc primary. I would not be concerned about the JASO rating. I have been running Rotella T6 oil in my can ams and cfmoto. It is also wet clutch compatible but a good oil and priced good.
2013 Z6 Trail
Iron Baltic skid plates
UE Boom Speaker mount
RZR 800 Shocks
Mostly stock trail riding
25g. Rollers and A1

2016 Outlander max 570
Too new for mods yet

Offline Kurt

  • Junior Member
  • **
  • Posts: 17
    • View Profile
  • Location: Alberta
Re: correct oil
« Reply #2 on: July 12, 2017, 02:44:07 PM »
Perfect, T6 is what I was hoping to go with since I have it in bulk at work.

Thank you very much :)

Offline vantre

  • Junior Member
  • **
  • Posts: 3
    • View Profile
  • Location: Greece
Re: correct oil
« Reply #3 on: February 06, 2018, 12:45:37 PM »
Is corect that (oil 0-40)? In the Service Manual say SAE15W-40/SG or higher...

Offline NMKawierider

  • Global Moderator
  • Guru
  • *****
  • Posts: 5397
  • 2015 ZForce 800 EPS
    • View Profile
    • Visit my YouTube Channel
  • Location: Albuquerque, NM
Re: correct oil
« Reply #4 on: February 06, 2018, 01:08:10 PM »
Is corect that (oil 0-40)? In the Service Manual say SAE15W-40/SG or higher...
Why 0w40? Why not 10w40. Its not that cold in Greece...is it?
2015 Z Force 800 (53") EPS -
Custom Air Intakes | Custom Exhaust Mod | SuperATV Harness | Custom Fenders | Custom Skid/Rock Sliders | 27" GBC Grim Reapers | Seizmik Mirrors |Конструктор (Rodin's) Doors | Dr Pulley Sliders | 1.5" Wheel Spacers | BENZ Silencer (as needed) | SATV Flip Windshield W\ Rear Shield | Dual Light Bars | Diamond Plate Storage | Magellan TRX7 GPS| Bandit Springs

My Videos On YouTube

Offline vantre

  • Junior Member
  • **
  • Posts: 3
    • View Profile
  • Location: Greece
Re: correct oil
« Reply #5 on: February 07, 2018, 05:43:51 AM »
Thank you for the quick answer...  I live in the mountains, two three months of winter are cold. I was a few failure to start up in the cold days ( -2c,-10c ). Use it (0-40) only in winter, and in summer; The summer season in Greece is very hot... +35c,+40c.

Offline Cosmosdan

  • Guru
  • *****
  • Posts: 1691
    • View Profile
  • Location: SW MN
Re: correct oil
« Reply #6 on: February 26, 2018, 10:17:23 PM »
-10c is not very cold. It should have started. Others have reported cold wether starting problems. Maybe there are some tips in this section or the 500 ho one. 0-40 seems pretty light, but Polaris ATVs run fine on it.
2013 Z6 Trail
Iron Baltic skid plates
UE Boom Speaker mount
RZR 800 Shocks
Mostly stock trail riding
25g. Rollers and A1

2016 Outlander max 570
Too new for mods yet